OpenRoads Designer CONNECT Edition SDK Help

Project Method

Projects the points collection of an element on the another element.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public  LinearPointProjectionResult Project( LinearPointCollection otherCollection, ProjectionBackOption projectionBackOption,bool trimBack,double tolerance)

Parameters

SettingDescription
  LinearPointCollection points collection of the projected element(the element to project onto)
  ProjectionBackOption type of projection
   true if we want “this” element to be trimmed by projecting the “projected” element to “this” element
   tolerance

Return Value

LinearPointProjectionResult the LinearPointProjectionResult of the projection

See Also